This project has moved. For the latest updates, please go here.

Getting strange exception when trying to build

Feb 17, 2011 at 5:37 PM

Hi there - I tried last night using the DEBUG version of the toolkit for the HTTP assembly.

I added a reference to the Http.dll and IO.dll.

Apologies as I don't have the code with me, but I'll type out roughly what I had:

 

using(HttpServer httpServer = new HttpServer(new MyHttpHandler())
{
}

...

public class MyHttpHandler : IHttpHanlder
{
} 

When i tried to build Visual Studio was throwing was reporting an error with the code, however the error read as a byte! Like 0x08....  
Any ideas what's not working?

Thanks!

Feb 18, 2011 at 12:32 AM

Never mind I figured out what was happening. From tracing through a few of your blogs I found that there are two separate compilations. One complied for a windows machine and one compiled for the .Net Microframework device. It appears that the ones that I wanted (ones for the microframework) are prefixed with "Micro".

I think you should change the folder structure to reflect this or make it highly visible in the documentation/home page.

Thanks for your contributions.